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BEGINNER ELEMENTARY OS PANTHEON DESKTOP USAGE 
GUIDE

Source URL

This guide will show you how to use elementary OS Pantheon desktop. Pantheon is default 
desktop in elementary OS. After our first guide for GNOME 3, this second guide is intended 
for beginner in elementary OS (especially ex. Windows users). You will learn how to use 
Pantheon for daily usage. You won't learn any technical or historical side of Pantheon. You 
will just work with it. I use elementary OS 2 Luna here.

Anatomy

Pantheon anatomy is basically GNOME 3 but 
Pantheon is simpler. You find only 5 main 
components here.

1. Menu. Can be accessed by Win + Space 
or click.

2. Time. Calendar and current time.
3. System tray.
4. Dock. Elementary's dock is called Plank.
5. Workspaces. Elementary's workspace 

switcher is placed on the bottom.

Concepts

If you were using Windows before, there are concepts you should get before you use 
Pantheon. 

• Pantheon usage is basically focused on top panel and bottom dock.
• Pantheon designed in similar visual appearance with Mac OS X desktop, not 

Windows.
• Pantheon has bottom dock by default, to replace Windows taskbar panel.
• Pantheon has no bottom taskbar, same with Mac OS X, different with Windows.
• Pantheon has multiple desktop (or multiple workspace), same with Mac OS X, 

different with Windows.
• You see your running applications by seeing on the dock.
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Launch Apps

You access your app by menu or by bottom dock (similar 
with GNOME 3). You open the menu by Win + Space or 
clicking Applications label on top panel. You open an app 
from bottom dock by single-clicking its icon. 

Create A Shortcut

 

Open an app, right-click on its icon 
when running, select Keep in Dock. 
That app icon will stay on the 
bottom dock. Pantheon is not 
Windows, so it has its own way to 
create desktop shortcut. 

Multiple Desktop

You can switch workspace by pressing Win + S. Pantheon workspaces is placed at the 
bottom, similar with right panel for workspaces in GNOME. 
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Work with Workspaces

When opening workspace switcher 
(Win + S), app icons will appear on 
the bottom of every workspace box. 
To move an app to another 
workspace, drag the icon to another 
workspace box. See picture above. 

Spread Windows

To see window overview, press Win + W. It is similar with Mac OS X Expose.

Alt+Tab

To switch between running windows, press Alt 
+ Tab. Switching will use bottom dock as 
window indicator representation.
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Notification 

 
Pantheon will show you a nice popup in top-left corner 
every a notification is given by an app.

System Tray

 

Pantheon system tray is placed on top panel. It is similar with Mac OS X tray. Any tray app 
such as Telegram will also placed there.

Reference

https://elementary.io/docs/learning-the-basics
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BLAM, A DEKTOP RSS FEED READER FOR UBUNTU
Source URL

Blam is one of the most user friendly RSS feed reader in Ubuntu. Blam can manage both 
Atom or RSS feed. You can read many sites without visiting them anymore. You can 
subscribe to any number of site, print the pages out, and set custom update intervals. It is 
created for GNOME environment. So, it will match your Ubuntu Unity.

Install Blam

By GUI, you can look for it in Ubuntu Software Center.

By Terminal, use command below.

sudo apt-get install blam  

Use Blam

For first usage, press Reload to redownload all built-in RSS subscriptions.
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To add your favorit RSS feed, insert it by menu Channel > Add > paste the RSS URL and 
name it > OK. For example, you can use Ubuntubuzz RSS Feed or Atom Feed.
To remove a feed, right click on the entry on the left panel > remove. 
To set interval time, open Edit > Preferences > set the value on the second line.
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BEGINNER MATE DESKTOP USAGE GUIDE
Source URL
 
MATE is a new desktop environment developed as GNOME 2 successor. MATE is a popular 
desktop now because of Linux Mint bundling and followed by Ubuntu MATE appearances. 
This article will guide you around the basic usage of MATE desktop. I hope you can apply 
this guide into your daily life with MATE desktop. You won't learn any technical or historical 
side of MATE. I write this article based on MATE 1.8.2 and Ubuntu MATE 15.04.

Anatomy

1. Menu for applications.
2. Menu for user folders.
3. Menu for system tools.
4. Shortcuts on panel.
5. System tray.
6. Time and date.
7. Shut down.
8. Workspaces.
9. Show desktop.
10. Shortcuts area.

Concepts

1. MATE is basically GNOME 2.
2. MATE workflow is focused on its panels. Either top or bottom.
3. MATE differs menu in 3 categories: applications, places, and system.
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4. MATE has some parts of traditional desktop metaphor such as desktop shortcut icons 
(similar with Windows) and taskbar (idem).

5. MATE has large aspects for customization such as desktop layout, compositing, 
themes, iconsets, and so on.

Launch Apps

To launch your applications, use Applications menu. You will use a GNOME 2-like menu. You 
look for apps one by one according to its category. To launch a favorite folder, use Places 
menu. To open system-related apps such as Settings or Logout function, use System menu. 

Create A Shortcut

To create a desktop shortcut icon, open MATE 
menu > right-click on an app entry > Add this 
launcher to desktop.  
To create a panel shortcut icon, do the same 
thing but select Add this launcher to panel.
Taskbar

Different with GNOME 3 or Elementary 
Pantheon, MATE brings GNOME 2 taskbar. It is 
basically same with Windows taskbar. You can 
switch between running apps by using it. 
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Alt+Tab

To switch between running apps in MATE, press 
Alt + Tab. It is basically same with another 
desktops.

Multiple Desktop

MATE as a GNOME 2 successor, has multiple desktop concept. You can switch between 
existing desktop to another or place each app in one suitable desktop. You may create more 
than 4 desktops. This desktop term, also called virtual desktop or workspace.

Work with Workspaces

To move a window into another workspace, right-
click on its title bar and select the desktop you 
want.  

System Tray

System tray is placed on the top 
panel along with time and power 
menu. You get basically volume, 
network, battery (if you are using 
laptop) applet. Another tray 
program such as Banshee will stay 
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on there.

Reference

http://mate-desktop.org 
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CREATE GIF FROM VIDEO WITH FFMPEG ON LINUX
Source URL
 
To easily convert a MP4 video into a GIF image, you can use ffmpeg and ImageMagick 
convert in Linux. First, you extract the video into frames in JPEG with ffmpeg. Second, you 
join all JPEG frames into a single GIF image with ImageMagick convert. I use MP4 format as 
example but you may use another as long as it is supported by ffmpeg. Below I explain the 
steps.

Extract the Video

1. Create a folder named frames in the same directory with your MP4 file.
2. Use command ffmpeg -i video_file_name.mp4  -r 5 'frames/frame-%03d.jpeg'. For 

example, see picture below.
3. Check frames folder. It should contains all frame images from the MP4. How many, it 

depends on your video size. 

Join All Frames

Use command convert frames/frame*.jpeg output.gif.
You get your GIF named output.gif in the same directory with your MP4. How long the 
process, depends on your processor.
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Explanation

1. -r 5 in ffmpeg is option for FPS value. Bigger means better quality, but slow. Smaller 
means lower quality, but faster.

2. %03d is a variable for sequential number. It gives your JPEG frames sequential 
filename numbers in decimal form.

3. The convert command above is intended to unite all sequential JPEG images into 
single GIF image.

4. You may modify commands above my reading man ffmpeg and man convert to suite 
your needs. You will get many examples to try. Explore them yourself.
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SSH TUNNELING IN LINUX MADE EASY PLUS DNS ENCRYPTION
Source URL

SSH Tunneling allows you "to force" your browser to connect to the internet via an 
encrypted connection. In other words, you can browse the internet securely so nobody will 
spy you. It means your IP address will be hidden from the outside and with some little 
config you also get your DNS request encrypted. It is a different thing compared with our 
latest OpenVPN and DNSCrypt guide. By SSH Tunneling, you get both internet line and DNS 
request encrypted in one blow. Yes, it is easy to do by just three steps. The only 
requirement is your SSH account. Please understand that I am not a phreaker or doing any 
phreaking stuff here. What actually we will do is to  create SOCKS proxy and tunnel all 
connections via that SOCKS by using ssh.

1. Command

ssh -fCND 127.0.0.1:1080 yourusername@yourserver.com  

• -f: this option tells SSH to run on background so you can close the Terminal safely.
• -C: compress all data.
• -N: tells SSH to do only tunneling and no command executed remotely.
• -D: use address IP:PORT like 127.0.0.1:1080 above.
• yourusername: change it with your SSH account username.
• yourserver.com: change it with your SSH server address.

You may refer to man ssh to get more information.  If your Terminal goes back to prompt 
after ssh command and login, then it means your ssh command is done. Check it by 
command ps aux | grep ssh.
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2. Configuration

Firefox: Preferences > Network > Settings > SOCKS > fill the IP 127.0.0.1 and port 1080.
Chrome: Settings > Proxy > SOCKS > fill the IP 127.0.0.1 and port 1080.

3. Test Your Connection

Yes, by just those two steps, you have your 
connection encrypted securely. To check it, simple 
ask for your IP address to Google. Or, use tcpdump 
to examine whether your connection is being 
forwarded or not.

• Google: type "what is my ip" and see that your 
IP is changed into the SSH server IP. Now, 
nobody knows you are you. They know only 
the SSH server, not you. 

• Tcpdump: type command sudo tcpdump -i 
wlan0 (for WLAN) or sudo tcpdump -i eth0 
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(for LAN) or you may specify your own interface. See that tcpdump shows you that 
your connection is being forwarded to a new address which is your SSH server 
address. 

Bonus

By just using those two steps, you get a secure connection (it is encrypted) but you have no 
DNS request encryption yet. This DNS request encryption is very useful so nobody will spy 
what you browse and you will be safe from DNS hijacking. How to do it? You can configure 
Firefox or Chrome to do that. Here the steps.

• Firefox: open address about:config in address bar > search for 
network.proxy.socks_remote_dns > change the value into true.

• Chrome: close your chrome first > open Chrome via Terminal with complete 
command like this chromium-browser --proxy-server="socks5://127.0.0.1:1080" 
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--host-resolver-rules="MAP * 0.0.0.0 , EXCLUDE 127.0.0.1"

Notes

• SSH tunneling or ssh port forwarding is very useful in security matter. You can 
browse any website anonymously. But you get more advantages, such as passing 
through the internet limitation by above DNS request encryption.

• I mentioned "browser" above doesn't mean that it is limited only for browser. Any 
other internet application such as email client, IRC client, torrent (if your server 
supports it), or whatever can use this SSH tunnel too. So as a summary, with SSH 
tunneling you get secure browsing plus secure IRC, email, torrent, download 
management, FTP, and so on. Just configure them to connect via SOCKS 127.0.0.1 
port 1080.

Reference

• http://stuf.ro/passing-all-traffic-through-ssh-in-ubuntu   
• http://makandracards.com/theogfx/3465-force-chrome-to-tunnel-dns-requests-  

through-a-ssh-socks-proxy 
• https://www.chromium.org/developers/design-documents/network-stack/socks-  

proxy 
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HOW TO INSTALL SMPLAYER IN UBUNTU
Source URL
 

SMPlayer is an open source video player which included 
all codecs once you install it. By installing it, you can 
play any video or audio without installing Ubuntu codec 
packages first. You can install SMPlayer from PPA 
repository. SMPlayer official website is at Sourceforge. 

The Commands

sudo add-apt-repository --yes ppa:rvm/smplayer  
sudo apt-get update  
sudo apt-get install smplayer smplayer-themes smplayer-skins  

Note: --yes option assumes you will answer yes anytime apt asks for permission. This will 
download 16 MB of packages and use 55 MB space after installation. files This PPA 
maintained by rvm.

Run SMPlayer

 
You can open a video by right-clicking the file and choose open with SMPlayer. You can also 
open SMPLayer from Ubuntu menu.

Reference

 
• http://smplayer.sourceforge.net/en/downloads   
• https://launchpad.net/~rvm/+archive/ubuntu/smplayer  
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HOW TO INSTALL KDE KMPLAYER IN UBUNTU
Source URL
 

KDE has an open source video player named KMPlayer 
(not to be confused with Pandora KMPlayer). KMPlayer 
is actually a GUI for MPlayer. So, installing KMPLayer 
will also install MPlayer and many KDE dependencies. 
KMPlayer is available in Ubuntu official repository. 
Here how to install it.

Install Via Terminal

sudo apt-get install kmplayer  

This will download approximately 86 MB of packages and use 230 MB space after install. 

Install via GUI

Open Ubuntu Software Center and search for KMPlayer then press install button.

Open KMPlayer

You can right-click any video file then choose open with KMPlayer. Or you can open 
KMPlayer first from menu.
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BEGINNER KDE DESKTOP USAGE GUIDE
Source URL
 
This guide will explain you how to use KDE desktop for daily usage. After our third MATE 
desktop guide, now it is our fourth about KDE. KDE is a traditional desktop for Linux which 
has similar appearance with Windows. KDE is very customizable, feature rich, and easy to 
use. This guide will not explain any of KDE technical or historical side. This article is written 
for those who never use Linux or KDE before. I use KDE 4.10 on Ubuntu 12.04 for this 
article.

Anatomy

KDE is very customizable. But there is a default visual appearance you can understand. 

1. KDE Menu. A traditional menu like in Windows 95 or Windows Vista.
2. Workspace Switcher. You change workspace with this.
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3. Shortcut icons. Same like Windows, you can place app icon on the taskbar panel.
4. Taskbar. Same like Windows, your running apps will appear here. 
5. System tray. Default KDE tray plus any tray app will appear here. 
6. Date and calendar. 
7. Panel Tool Box. It is a desktop controller where you can add widget, lock widget, 

change wallpaper, and so on here. 
8. Note: because KDE is customizable, every part of its desktop can be moved at 

anywhere. What you see above just common default layout. 

Concepts

1. Basically, KDE has same concepts with Windows. They share same traditional desktop 
metaphor.

2. KDE has bottom panel, menu, and taskbar like Windows.
3. KDE calls its desktop as Plasma. So you will see many Plasma terms everywhere. 
4. KDE has its own Control Panel, same like Windows.
5. KDE desktop is distinguished into two components, panel and widget. KDE calls 

widget as Plasmoid.
6. KDE desktop has single-click behavior, while Windows desktop has double-click 

behavior.

Launch Apps

To launch an app in KDE, open menu then search your app 
name. Or, use category to find manually your app i.e. Firefox 
in Internet category.

Create Shortcut

To create desktop shortcut, you can do the same thing like in Windows. Choose one of 
these:

• Right-click one app icon inside the menu > Add to Desktop. 
• Drag one app icon inside the menu > drop on the desktop. 
• Add widget > select Quicklaunch > drag it to the desktop > right-click on the widget > 

add new shortcut.
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Alt+Tab

KDE also has window switching 
behavior, same like Windows. It uses 
Alt+Tab.

Spread Window

To do spread window, choose one 
of these methods: 

• Push cursor into top-left 
corner of display (it is 
called hot corner). 

• Press Alt+W or change the 
shortcut key by your own 
preference. 

KDE spread window (similar with 
GNOME and Pantheon) is another 
way to switch between app 
windows. It is an Alt+Tab 
alternative so you can switch what app visually and by overview. 

Multiple Desktop

KDE multiple desktop feature 
appears by default as Virtual 
Desktop icon on bottom-left 
panel near the menu. By clicking 
on it, you switch your focus into 
another workspace. 

KDE has multiple desktop (multiple workspaces) concept. You may have more than one 
desktop and you may switch to any desktop quickly. Multiple desktop is different with just a 
Windows Taskbar panel. In Windows, you have only one taskbar and one desktop. But in 
KDE, in multiple desktop, you may have many desktops and taskbars as many as your 
desktops.
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Work with Workspaces

You can place Libreoffice in 
desktop 1, Firefox in 2, Amarok in 
3, Terminal in 4, so you can give 
your focus to Libreoffice on 
current desktop while another 
apps don't disturb you in another 
desktop. To work with it, hold the 
key: Move to Workspace. Choose 
one of these methods:

Right-click on titlebar > Move To 
Desktop > select the number. 
Use Desktop Grid  > drag a 
window > drop to another workspace.
To switch your focus into another workspace, choose one of these methods:

• Ctrl+Alt+Right/Left.
• Use Desktop Grid.

Add Widget

You can add or remove desktop 
widget in KDE. To add a widget, 
click on Panel Tool Box (bottom-
left button) > Add Widget > 
select one > drag it into the 
desktop.  To remove a widget, hover cursor on the widget > click close (X) button.

Lock Widget

You can lock all widgets on their position so no one can add, remove, or 
move them. To do that, click Panel Tool Box > More Settings > Lock 
Widgets. To unlock, do the same thing. 
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System Tray

KDE system tray is very similar with Windows' one. The only one difference is KDE has 
Klipper as clipboard management tool. It is represented as scissor icon. But when it comes 
to network manager, KDE has a neat interface where it divided into left and right columns. 
Right column is the list of network available, while left column is the controller and statistic 
for the network being used. 

Reference

https://www.kde.org/workspaces/plasmadesktop 
https://userbase.kde.org/An_introduction_to_KDE 
https://userbase.kde.org/Plasma 
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HOW TO CREATE APA STYLE BIBLIOGRAPHY IN LIBREOFFICE
Source URL

Libreoffice has ability to create APA Style bibliography even any other style. In previous 
Libreoffice article, we explained about basic bibliography creation. Now, we introduce how 
to make APA style with Libreoffice. Don't worry, it is automatic. The only requirement is you 
should know APA Style format. We take only the book format for example here.

APA Style Format for Book

Au. (Ye). Ti. Ad: Pu.

Au: Author
Ye: Year
Ti: Title
Ad: Address
Pu: Publisher

You should pay attention to every character because they all will be used.

1. Bibliography Database

Firstly, you should enter all your references (books, journals, etc.) into the Libreoffice 
Bibliography Database. How to do it is explained in our previous article.

2. Create APA Style Template

Now, you should translate the APA Format above into Libreoffice template for bibliography. 
To do it, do methods below.

1. Open menu Insert > Indexes and Tables > Indexes and Tables.
2. In the dialog appears, select Bibliography from Type options.
3. Open tab Entries. 
4. Select Book from the Types column on the left. Yes, we only create bibliography for 

books (excluding journals, webs, and others).
5. On the Structure row, remove all buttons (Sh Au Ti Ye) by selecting and then click 

remove. Remove them all. 
6. On the same Structure row, place your cursor in the blank space. Now, insert your 

APA Style Format above here. The format is: Au. (Ye). Ti. Ad: Pu. respectively. Enter 
one by one from selections available under Address button.
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7. Click on Ti button you have created. 
On the Character Style options, 
select User Entry, then click Edit. 
Give it Italic. Yes, the book title will 
be italicized in every of your 
bibliography. 

8. On the Sort By, select Content.
9. On the Sort Keys, select number 1, 

select Author(s). Yes, all bibliography 
will be sorted alphabetically by 
author's name. See picture below.

10. Press OK. Your preparations for APA 
template are done.

11. You must see an empty grey 
Bibliography entry appears in your 
article text in your latest cursor 
position. It is okay. 

Note: I know these are seems complicated. 
If you are confused, you may refer to video I 
refer below. 

3. Cite in Article

Now, you should cite your book references inside your article text. For example, (Bob, 2015) 
in paragraph one and (Jim, 2009) in paragraph two. You can do it by menu Insert > Indexes 
and Tables > Bibliography Entry. You can follow our previous article about it.

4. Create Bibliography

Now, you can create the final bibliography list on the last page of your work. To do it, just 
right-click on the grey empty Bibliography entry in your text > Update.

5. Set Indentation Spacing

To create hanging indentation like in 
real bibliography works, you must edit 
Bibliography paragraph style first. To do 
that, right-click on the bibliography list > 
Edit Paragraph Style > open Indent and 
Spacing tab > fill Before Text = 1.00cm 
First Line = -1 Below Paragraph = 0.2cm. 
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See picture. Your APA Style bibliography is done.

Result

Reference

• https://www.youtube.com/watch?v=FeAaQ88-2FY   (video to create APA style in 
Libreoffice)

• http://www.sciencebuddies.org/science-fair-  
projects/project_apa_format_examples.shtml  (basic APA Style text guide)

• http://bengkelubuntu.org/teks/libreoffice/cerdas-menyusun-tugas-akhir-dengan-  
libreoffice-writer-cc.pdf (big guide for Libreoffice science writing in Indonesian 
language) 
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EXPORT SCRIBUS FILES FOR WORKING IN ANOTHER COMPUTER
Source URL
 
When you work with Scribus, you save into SLA file format. This SLA file is different with 
ODT or PDF format. It doesn't contain any picture or file you use inside your design. To 
proof that, just look at the file size. If you give your SLA file to another Scribus users, they 
won't open the SLA perfectly because all the pictures or files are still in your computer. Not 
inside the SLA file. Now, how to bundle all pictures or files so you can give it to your 
partners or you use it for working with another computer? Here the methods.

1. Open Scribus. 
2. Open your SLA file. 
3. Open menu File > Collect for Output. 
4. Check Include Fonts and Include Color Profiles in the dialog appears. 
5. Select folder to save all files. 
6. Press OS. 
7. Go to that folder, ZIP the folder. You may use built-in Ubuntu archive program or 

anything. 

Now you can give the ZIP file to your partners or use it everywhere you find Scribus. 
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HOW TO CREATE LETTERPRESS EFFECT IN INKSCAPE
Source URL
 
Inkscape can make letterpress effects by drop shadow and masking manipulations. It is a 
short basic tutorial so you can develop it yourself then. Prepare yourself, because Inkscape 
drop shadow eats many computer resources. I will show you how to create it. 

Requirements

• Inkscape 0.48
• FreeSans font
• Drop shadow
• Radial and linear gradation

1. Background

First, create a grey rectangle with the 
dimension 744 x 450. This is the background. 
We should give it a linear gradation 
vertically.

2. Foreground Masking

Create a smaller rectangle on top of your background. Fill it red. Write a text with FreeSans 
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bold font on top of red rectangle. Select the text and the red rectangle > menu Path > 
Difference. Now, we have a red rectangle mask.

3. Drop Shadow

Create drop shadow for the red rectangle. 
Ge it from menu Filters > Shadow and Glow > 
Drop Shadow. Give it values Blur Radius = 
3.0, Opacity = 10, Horizontal offset = 6.0, 
Vertical offset = 5.0. You may decide the 
values yourself.

4. Foreground Radial Gradation

Create radial gradation for the red rectangle. 
Press G (Gradation) and select radial from 
gradation tool options on the toolbar.

5. Soft Edge Outline

Create soft edge outline for the foreground. Give it 1 px thickness, white color, and 20% 
opacity.
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6. Finishing

To finish your work, resize your background 
until it is smaller than your foreground. Read 
bonus below to make this process quicker on 
slow computers.

5. Exporting

Select foreground > Ctrl+Shift+E > name it > 
press Export.

Our final result will be like this. 
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Bonus

1. Use menu View > Display Mode > No Filters so all drop shadows and another effects 
will be temporarily disabled. It is very effective to improve Inkscape speed when you 
are using drop shadow. 

2. Use Snap to Page Border so you can easily create the first background above. 
3. Give drop shadow effect more than once until you can get thicker shadow you want.
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EASY PROXY SWITCHING IN CHROME AND FIREFOX (FOR SSH 
TUNNELING OR ELSE)

 Source URL

After trying SSH Tunneling, probably you feel it is painful to change proxy settings manually 
every time. And maybe you have another proxy so you need a quick proxy changer. There 
are extensions to help us change the proxy settings by just a click. It is SwitchySharp for 
Chrome and Proxy Selector on Firefox. Of course, you may create different proxy 
configurations as many as possible if you have more than one. I will show you how to install 
and use it.

Firefox

1. Open Firefox Add-ons page (about:addons).
2. Search for "proxy selector". 
3. Press install button. You need internet connection for it. 
4. After installing, restart your Firefox.
5. When your Firefox is up again, you get a new icon (proxy 

selector) on the toolbar. Open it > Manage Proxies. 
6. Fill the blanks with your proxy configuration. Name it yourself 

(e.g. SSH). To set a SSH Tunnel SOCKS Proxy, see our previous 
article.

7. To use a proxy (or SSH Tunnel SOCKS), click the icon and select. 
To disable a proxy, just click it and set to No Proxy. 

If you are using SSH Tunnel SOCKS proxy, then to test whether the SSH Tunnel works or not, 
just type what is my ip on Google.

Chrome

1. Go to this official page or search switchysharp chrome on 
Google.

2. Install that SwitchySharp extension. Yes, you must use Google 
Chrome or Chromium and are not in incognito mode. 

3. After installing, go to the SwitchySharp Options and fill your 
proxy settings. Name it as a new profile. To set SSH Tunnel 
SOCKS proxy, see our previous article. 

4. To use a proxy, click on the SwitchySharp (earth icon) button > 
click your proxy name. To disable your current proxy, click 
Direct Connection. 
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TAKE SCREENSHOT OF WEB PAGE ON CHROME AND FIREFOX
Source URL
 
Probably you need to take a web page screenshot. You can do that easily on Chrome 
(Chromium) and Firefox by an extension named Awesome Screenshot. You can take the 
whole or part of page. You can annotate it with line or text and color after taking. I will 
show you how to install and use it.

Firefox

1. Go to Firefox Add-ons page (about:addons). 
2. Search for "awesome screenshot".
3. Install it. 

You get a camera lens icon on your toolbar. That is Awesome Screenshot. 

Chrome

1. Visit this official page or search awesome screenshot chrome in Google. 
2. Install it. 

You get same camera lens icon on your toolbar.

Taking A Whole Page

You can do these methods both in Chrome and Firefox.

1. For example, you want to take ubuntu.com page. 
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2. Visit that page. 
3. Click on the lens icon > Capture Entire page.
4. A new tab will be opened. In this tab, you may edit / annotate the screenshot. Then 

click Done button. 
5. The page appearance will be changed, then click Save button. Save the screenshot in 

your favorite folder. 

Taking A Part of Page

Same with above but select Capture Selected Area.

Editing Screenshot

You may draw straight lines, 
rectangles, ovals, blur some 
contents, and crop the image. If 
you are not satisfied with the 
result, you may save and edit it on 
GIMP.
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CHANGE KEYBOARD LAYOUT INTO ARABIC WITH TERMINAL 
COMMANDS IN LINUX

Source URL
 
We can easily change our keyboard layout in Linux by Terminal commands. It is easier and 
faster at many times compared to GUI. You can change layout by just up or down arrow key. 
Remember, many cases happened when people change their layouts and they can't revert 
them back. Avoid it by number 1 step below.

1. Set Default Layout

Yes, you must do command for default layout first (US) or you will find difficulty to revert 
the setting into default again.

setxkbmap  -layout us  

2. Set Arabic Layout

We have 'parent language' (Arabic) and also 'children language' as variant/dialect 
(Buckwalter etc.).

setxkbmap -layout ara  

To set Arabic with Buckwalter variant, use this command:

setxkbmap -layout ara -variant buckwalter  
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Note: Buckwalter is an Arabic variant which has similar result with Multikey program on 
Windows while you may type A for ALIF, B for BA', T for Ta' (phonetically associated keys), 
and so on. Buckwalter variant helps us to write Arabic easily without any additional tool.

3. Revert Layout to Default

To revert your layout into default, call previous command. That's why you should do the 
first command before. Use up arrow key on Terminal so you can call the previous commands 
and choose

setxkbmap  -layout us  
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HOW TO REPACK GOOGLE CHROME/CHROMIUM EXTENSION
Source URL

In Google Chrome and Chromium, you can repack your installed extensions and reuse it 
anywhere. For example, you may install the extension in your other computers (without 
internet connection) or give it to your friends. Or, save it on USB stick so you can install it on 
any public computer you can use. It is very useful for offline users so I will tell you how. By 
using this guide, you will repack your extensions one by one. Every package will have .crx 
file extension.

1. Open Chrome Extension Settings

Open Menu > Settings > Extensions or just open URL chrome://extensions. Check Developer 
Mode.

2. Pack Extension

1. Click Pack Extension button. 
2. Click Browse at Extension root directory. 
3. Navigate it into /home/yourname/.config/google-chrome/Default/Extensions 

(Google Chrome) /home/yourname/.config/chromium/Default/Extensions 
(Chromium).

4. Open one folder. You know, the folder name is not human-friendly such as 
ajpgkpeckebdhofmmjfgcjjiiejpodla. You will know if you match that folder name with 
the extension ID of every installed extension. Click Pack Extension button.

5. Your extension is packaged. Check it in the same directory. It should have .crx 
extension.

6. You must pack one by one if you want all extension to be repackaged.

3. Test Install

To proof that the repacked extension is valid, install it 
again. To install, just drag it on Chrome Extension 
Settings page. When you see a notification Drop to 
Install, then drop it. You will find it is exactly the same 
with online installation.
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